Springen naar inhoud

Onjuiste uitkomst curve fit?


  • Log in om te kunnen reageren

#1

Oromis

    Oromis


  • >25 berichten
  • 39 berichten
  • Gebruiker

Geplaatst op 09 december 2010 - 21:18

Oke..

Ik heb een aantal meetgegevens in Graphical Analysis. Vervolgens voer ik een curve fit uit, waarbij ik zoek naar een vijfdegraads polygoon. Graphical Analysis vind een functie, en tekent die. De getekende grafiek lijkt inderdaad goed overeen te komen met de meetwaarden; de RMSE is 0,00038957. Maar als ik de functie vervolgens invoer in excel, of op mijn grafische rekenmachine, komt er een totaal andere grafiek uit, die voor geen meter klopt bij de meetpunten. Ik weet heel zeker dat ik de functie goed heb overgenomen. Iemand een verklaring?

Dit forum kan gratis blijven vanwege banners als deze. Door te registeren zal de onderstaande banner overigens verdwijnen.

#2

Oromis

    Oromis


  • >25 berichten
  • 39 berichten
  • Gebruiker

Geplaatst op 10 december 2010 - 01:32

Mensen, ik kom hier echt niet zelf uit. Dit is behoorlijk frustrerend. Hier is een afbeelding van de fit:

Geplaatste afbeelding

Het lijkt prachtig, maar als ik zelf de gegeven functie plot, krijg ik gewoon een compleet andere grafiek. Kan iemand hem plotten, en kijken wat hij/zij eruit krijgt? Ik weet zeker dat ik hem goed plot, maar ik kan me nauwelijks voorstellen dat het programma zo'n fout zou maken.

Hartelijk dank voor alle hulp!

#3

317070

    317070


  • >5k berichten
  • 5567 berichten
  • Moderator

Geplaatst op 10 december 2010 - 03:42

Schrijf eens neer welke functie je in de andere plotters ingeeft. M.a.w. welke functie denk je dat er op de afbeelding staat.
What it all comes down to, is that I haven't got it all figured out just yet
And I've got one hand in my pocket and the other one is giving the peace sign
-Alanis Morisette-

#4

Oromis

    Oromis


  • >25 berichten
  • 39 berichten
  • Gebruiker

Geplaatst op 10 december 2010 - 07:49

Bedankt voor je reactie.

Op mijn grafische rekenmachine ziet het er als volgt uit:

\Y3=449.8-1.256E4X+1.401E5X^2-7.806E5X^3+2.17E6X^4-2.408E6X^5

Wanneer ik deze functie plot, met de windowinstellingen gelijk aan die van bovenstaande afbeelding, krijg ik alleen een schijnbaar verticale lijn links in beeld, niets wat lijkt op bovenstaande grafiek.

#5

Oromis

    Oromis


  • >25 berichten
  • 39 berichten
  • Gebruiker

Geplaatst op 10 december 2010 - 15:33

Het probleem is opgelost.

Graphical Analysis berekent de paramaters op 9 decimalen nauwkeurig, maar geeft (tenzij anders ingesteld) maar twee of drie decimalen weer. Omdat het een vijfdegraads functie betreft, hebben minimale verschillen in de paramaters een aanzienlijk effect op de uiteindelijke uitkomst, waardoor het inderdaad lijkt alsof men te maken heeft met een totaal andere functie.





0 gebruiker(s) lezen dit onderwerp

0 leden, 0 bezoekers, 0 anonieme gebruikers

Ook adverteren op onze website? Lees hier meer!

Gesponsorde vacatures

Vacatures