Springen naar inhoud

Nieuwsbrief opmaak


  • Log in om te kunnen reageren

#1

jkien

    jkien


  • >1k berichten
  • 3053 berichten
  • Moderator

Geplaatst op 24 juni 2011 - 05:40

De WSF-nieuwsbrief van vandaag vertoont bij mij twee opmaakfoutjes: de aanhef bevat een code die automatisch ingevuld had moeten worden, maar dat heeft niet gewerkt, en letters met een accent zijn verminkt:

Beste {member_name}, ... bacteri�n ... m��r dan gemiddeld ... �Introduction to Multiphysics� CD.

Dit forum kan gratis blijven vanwege banners als deze. Door te registeren zal de onderstaande banner overigens verdwijnen.

#2

Ger

    Ger


  • >5k berichten
  • 16444 berichten
  • Technicus

Geplaatst op 24 juni 2011 - 08:17

We maken gebruik van een nieuwe service om de nieuwsbrieven te verzenden. Daarbij blijken een paar dingen nog niet goed ingesteld te zijn helaas. We zijn ervan op de hoogte en weten ook de oorzaak (en hoogstwaarschijnlijk de oplossing). De volgende keer zou het dus helemaal goed moeten gaan!
"Knowledge speaks, but wisdom listens."
- Jimi Hendrix -

#3

DePurpereWolf

    DePurpereWolf


  • >5k berichten
  • 9240 berichten
  • VIP

Geplaatst op 24 juni 2011 - 12:44

Ik heb geen probleem met de accenten. Even in de html gekeken en er staat niets raars:

“Introduction to
Multiphysics”

Ik kan het ook hier typen ALT + '0147' = “ Het is dus volgens mij gewoon ascii
Zie je het hier weer?
Het is raar dat je pc de symbolen niet herkent. Welke versie windows? Internetexplorer? Email-programma?

#4

In physics I trust

    In physics I trust


  • >5k berichten
  • 7384 berichten
  • Moderator

Geplaatst op 24 juni 2011 - 14:06

Kan dat in ieder geval niet voorkomen worden door wat je hier vindt?
"C++ : Where friends have access to your private members." — Gavin Russell Baker.

#5

Ger

    Ger


  • >5k berichten
  • 16444 berichten
  • Technicus

Geplaatst op 24 juni 2011 - 14:14

Het probleem zit hoogstwaarschijnlijk in de encoding. In de nieuwsbrief input wordt de tekst opgeslagen als ISO 8859-1. Ik heb het vermoeden (maar dat moet ik nog bevestigen) dat het verzenden van de nieuwsbrief gebeurt in UTF-8. Voor het gros gaat dit goed, maar bij speciale tekens gaat dit vaak mis. Het programma waarmee je het resultaat (de nieuwsbrief dus) bekijkt, probeert het dan zo goed mogelijk weer te geven, maar op sommige plaatsen faalt het dan, resulterend in vraagtekens, blokjes of andere rare creaties. Het ene programma is hier beter in dan het andere, wat ook de verschillen verklaart.

De oplossing ligt dus voor de hand: de input en output met elkaar op 1 lijn krijgen. ;)
"Knowledge speaks, but wisdom listens."
- Jimi Hendrix -

#6

jkien

    jkien


  • >1k berichten
  • 3053 berichten
  • Moderator

Geplaatst op 24 juni 2011 - 15:57

Ik heb geen probleem met de accenten.
Even in de html gekeken en er staat niets raars: “Introduction to Multiphysics”
Ik kan het ook hier typen ALT + '0147' = “ Het is dus volgens mij gewoon ascii
Zie je het hier weer?

In jouw quote zie ik geen rare tekens i.p.v. aanhalingstekens.

Het is raar dat je pc de symbolen niet herkent. Welke versie windows? Internetexplorer? Email-programma?

Windows 7 (service pack1), internet explorer 9, outlook 2003

#7

Drieske

    Drieske


  • >5k berichten
  • 10217 berichten
  • Moderator

Geplaatst op 25 juni 2011 - 10:47

Gewoon ter extra informatie (je weet nooit dat het handig is ;)): ik heb hetzelfde probleem met de accentjes in de nieuwsbrief. Eerste keer dat dat voorvalt.

Ik gebruik mozilla thunderbird. Ter volledigheid:

WSF_thunderbird.png
Zoek je graag naar het meest interessante wetenschapsnieuws? Wij zoeken nog een vrijwilliger voor ons nieuwspostteam.

#8

Ger

    Ger


  • >5k berichten
  • 16444 berichten
  • Technicus

Geplaatst op 25 juni 2011 - 11:14

Ik denk dat iedereen het zal hebben. De een iets erger dan de ander, maar ik denk niet dat er iemand zal zijn die alles goed zal hebben staan. Het is een foutje geweest bij het versturen.
"Knowledge speaks, but wisdom listens."
- Jimi Hendrix -

#9

Drieske

    Drieske


  • >5k berichten
  • 10217 berichten
  • Moderator

Geplaatst op 02 december 2011 - 20:56

Even melden: ik had het foutje bij deze editie ook. Met name hier:

..//.. WendyTje pleit dan ook voor een �€œJournal of experiments that failed to work�€�, om..//..

Zoek je graag naar het meest interessante wetenschapsnieuws? Wij zoeken nog een vrijwilliger voor ons nieuwspostteam.

#10

Ger

    Ger


  • >5k berichten
  • 16444 berichten
  • Technicus

Geplaatst op 03 december 2011 - 09:18

Ik zag het ook inderdaad. Het is specifiek bij de aanhalingstekens, voor de rest loopt wel alles goed. Het heeft te maken met het verschil tussen ASCII en Unicode. Emailprogramma's verwerken dat laatste helaas niet altijd even goed.

Technisch verhaal voor de geïnteresseerden:
Het gaat hier om de aanhalingstekens en . Dit zijn de zogeheten gekrulde aanhalingstekens (al zie je in dit lettertype weinig krul, maar in boeken e.d. zie je ze vaak genoeg). E-mailprogramma's werken (in HTML-modus) meestal echter met een beperkte subset van leestekens en herkennen alleen het rechte aanhalingsteken, ook wel de double quote genoemd: "
Die wordt voor beide ingezet als vervanging. Het is een beetje primitief en vraag me niet waarom ze het niet herkennen. Als je de modus namelijk op "tekst met opmaak" zet, dan worden de gekrulde aanhalingstekens namelijk wel netjes herkend...

Voor ons een leerpunt: de nieuwsbrief hierop nakijken de volgende keer.
"Knowledge speaks, but wisdom listens."
- Jimi Hendrix -





0 gebruiker(s) lezen dit onderwerp

0 leden, 0 bezoekers, 0 anonieme gebruikers

Ook adverteren op onze website? Lees hier meer!

Gesponsorde vacatures

Vacatures