Springen naar inhoud

[excel] probleem met kringverwijzing


  • Log in om te kunnen reageren

#1

zpidermen

    zpidermen


  • >1k berichten
  • 1623 berichten
  • Ervaren gebruiker

Geplaatst op 16 november 2011 - 11:25

Ik heb een declaratieformulier in Excel, maar ik moet daarbij in sommige cellen telkens dezelfde informatie zetten. In cel E6 staat bijvoorbeeld een plaatsnaam. In de cellen E7 t/m E20 moet daarbij telkens de plaatsnaam die in E6 staat, ingetypt worden. Dat kan natuurlijk handiger.

In de cellen A6 t/m A20 kan ik al dan niet een datum invoeren. Nu wil ik het volgende:

- Als in A7 een lege waarde staat, moet E7 leeg blijven.
- Als in A7 geen lege waarde staat, moet E7 de tekst van E6 krijgen.

Ik heb geprobeerd om dat op deze manier te doen:

E7 heeft als waarde: =ALS(A7="";"";E7=E6)

Maar zodra ik in A7 een datum invoer, krijg ik een waarschuwing over een zogenaamde kringverwijzing. Dat komt omdat in E7 een formule staat die naar zichzelf verwijst (het gedeelte E7=E6). Ik kan die waarschuwing voorkomen door in Excel bij opties iteraties in te schakelen, maar wanneer ik nu een datum in A7 invoer, krijgt E7 de waarde: ######.

Hoe moet ik dit oplossen?
Beter kaal als geen haar want een kip snurkt

Dit forum kan gratis blijven vanwege banners als deze. Door te registeren zal de onderstaande banner overigens verdwijnen.

#2

Landro

    Landro


  • 0 - 25 berichten
  • 18 berichten
  • Gebruiker

Geplaatst op 16 november 2011 - 11:46

probeer
=ALS(A7="";E6;"")
in E7

Je mag vanuit een cel namelijk niet naar diezelfde cel verwijzen.

http://office.micros...gin=HP010342486

Veranderd door Landro, 16 november 2011 - 11:52


#3

zpidermen

    zpidermen


  • >1k berichten
  • 1623 berichten
  • Ervaren gebruiker

Geplaatst op 16 november 2011 - 12:26

Gevonden! Je bracht me op het juiste idee!

Ik heb nu in E7 de formule: =ALS(A7="";"";E6)
Ik hoefde de formule dus maar een heel klein beetje aan te passen door van 'E7=E6' te maken 'E6'.
Beter kaal als geen haar want een kip snurkt





0 gebruiker(s) lezen dit onderwerp

0 leden, 0 bezoekers, 0 anonieme gebruikers

Ook adverteren op onze website? Lees hier meer!

Gesponsorde vacatures

Vacatures