Springen naar inhoud

LM3914


  • Log in om te kunnen reageren

#1

Robbie

    Robbie


  • 0 - 25 berichten
  • 23 berichten
  • Gebruiker

Geplaatst op 23 oktober 2005 - 20:23

Hallo, ik heb al een aantal vragen gesteld over wat IC's, nu wil ik graag nog weten hoe ik een LM3914 moet aansluiten, ik wil hiermee een aantal LED's aansturen als volgt: ik ben bezig met een koffiezetapparaat, daarvan moet de temperatuur instelbaar zijn, ik wil de temperatuur van de koffie weergeven door middel van die LED's, ik wil 5 LED's plaatsen met daarbij de temperatuur vermeld. Ik wil de koffie regelen tussen 60 en 80 graden Celsius. Ik plaats 5 LED's dus bij de LED's komt te staan: 60, 65, 70, 75 en 80 graden Celsius. Als je de koffie dan instelt op bijvoorbeeld 70 graden dan moeten de eerste 3 LED's gaan oplichten als de koffie de 70 graden ook heeft bereikt.
Wie o wie kan mij wat meer vertellen over de LM3914???
Ik heb al wat datasheets.
Alvast bedankt!!

Dit forum kan gratis blijven vanwege banners als deze. Door te registeren zal de onderstaande banner overigens verdwijnen.

#2

Mrtn

    Mrtn


  • >1k berichten
  • 4220 berichten
  • VIP

Geplaatst op 23 oktober 2005 - 20:56

Google is je vriend; je zoekt een datasheet.
http://www.alldatasheet.com/
http://www.datasheetcatalog.com/

etc..
Heb je daar voldoende aan?
Of course, the theory of relativity only works if you're going west.
-Calvin-

#3

Robbie

    Robbie


  • 0 - 25 berichten
  • 23 berichten
  • Gebruiker

Geplaatst op 24 oktober 2005 - 13:36

Ik heb al datasheets, ik kan nu al wat LED's aansturen, maar heb nu het volgende probleem:
ik wil door middel van de brug van wheatstone een spanningsverschil creeren door in deze brug een PT-100 op te nemen. Deze PT-100 moet een temperatuursverschil van 20 graden Celsius waarnemen, namelijk van 60 tot 80 graden. Bij deze temperatuursverschil treedt een weerstandsverandering op van slechts 7 Ohm bij de PT-100. Ik heb gemeten dat het eerste LEDje oplicht als er een spanning van 130mV op de signal in poort van de LM staat, zo gaat het tweede LEDje aan bij 260 mV, het derde bij 390mV enz.... Zo wil ik er 5 aansturen. Heeft iemand een idee?
Alvast bedankt

#4

Paul Siemons

    Paul Siemons


  • >100 berichten
  • 193 berichten
  • Ervaren gebruiker

Geplaatst op 25 oktober 2005 - 20:48

Hallo,

Misschien ben je hier iets mee; is wel als voltmeter uitgevoerd?

Zie: http://www.uoguelph....ets/rx-volt.htm


Mvg,

Paul Siemons

#5

Robbie

    Robbie


  • 0 - 25 berichten
  • 23 berichten
  • Gebruiker

Geplaatst op 26 oktober 2005 - 21:18

Ik heb het probleem dat het maximale spanningsverschil wat ik uit de brug van Wheatstone kan halen met behulp van de PT-100 te klein is om de Leds aan te sturen.

#6

chablis

    chablis


  • >250 berichten
  • 420 berichten
  • Ervaren gebruiker

Geplaatst op 27 oktober 2005 - 14:16

Wel eens van een OpAmp gehoord?

Maar volgens mij heb je maar 0-5v nodig, dat moet toch makkelijk gaan met een PT100?

#7

Robbie

    Robbie


  • 0 - 25 berichten
  • 23 berichten
  • Gebruiker

Geplaatst op 28 oktober 2005 - 00:16

Uiteraard heb ik van een opamp gehoord, ik heb het ook al geprobeert, maar krijg het niet voor elkaar. Met de PT-100 krijg je nooit een spanning van 0-5 V uit de brug, omdat het weerstandsverschil maar 7 Ohm bedraagd tussen het bereik van 60 graden en 80 graden Celsius.

#8

Chriis

    Chriis


  • >250 berichten
  • 664 berichten
  • Ervaren gebruiker

Geplaatst op 28 oktober 2005 - 10:25

Ik heb even vluchtig naar het datasheet van de LM3914 gekeken.
Volgens mij kun je de range instellen door spanning wanneer ze allemaal uit moeten zijn op de RLO pin te zetten, en de hoogste spanning moet je op de RHI pin zetten. Dus met twee potmetertjes kun je de range gewoon instellen.
Zie http://cache.nationa...s/LM/LM3914.pdf Pag. 7.

#9

Robbie

    Robbie


  • 0 - 25 berichten
  • 23 berichten
  • Gebruiker

Geplaatst op 28 oktober 2005 - 16:06

Ook dat weet ik, daar heb je gelijk aan dat klopt helemaal, ik heb een aantal dingen geprobeert, maar het lukt me niet om hem aan de praat te krijgen naar behoren. Heb ook al een andere geprobeert, om te kijken of deze niet kapot is, maar daarmee lukt het ook niet.
Hij doet het wel gewoon, ik heb het namelijk geprobeert met een potmeter en dat werkt perfect.
Maar ik heb nu inmiddels de moed opgegeven, slecht he :roll:.
In ieder geval bedankt voor alle reacties.





0 gebruiker(s) lezen dit onderwerp

0 leden, 0 bezoekers, 0 anonieme gebruikers

Ook adverteren op onze website? Lees hier meer!

Gesponsorde vacatures

Vacatures