Springen naar inhoud

ALS- OF- EN- functies Excel


  • Log in om te kunnen reageren

#1

KoenM

    KoenM


  • 0 - 25 berichten
  • 3 berichten
  • Ervaren gebruiker

Geplaatst op 13 oktober 2009 - 17:11

Hey,

Voor school moet ik wat problemen oplossen die staan op de site:
http://www.projecteuler.net/
Nu ben ik bij een probleem aangekomen waarvan ik het denk op te kunnen lossen met de ALS- OF- en EN-functies van Excel.
Maar dit is de eeste keer dat ik hier gebruik van maak en ik ben bang dat ik jullie hulp nodig heb.
Om het hele probleem niet uit te hoeven leggen is het enige wat ik nodig heb het volgende:

In kolom A staat steeds het rijnummer (dit is me gelukt). Nu wil ik dat in kolom B een "1" komt te staan als de waarde in kolom A tussen de 1 en de 9 ligt, een "2" als de waarde in kolom A tussen de 10 en de 189 ligt etc...

Als iemand mij kan helpen dit uit te leggen, dan lukt de rest me hopelijk zelf wel.
Alvast bedankt,

Koen

Dit forum kan gratis blijven vanwege banners als deze. Door te registeren zal de onderstaande banner overigens verdwijnen.

#2

*_gast_Gerard_*

  • Gast

Geplaatst op 13 oktober 2009 - 18:48

Kun je wat meer toelichten wat je wilt?
Wat moet er in kolom B staan als er 191 staat ofwel wat betekent etc.?

Dit bijvoorbeeld met een ALS en een EN funktie werkt om als je rijnummer ligt tussen 0 en 9 een 1 te krijgen en anders een 2. Er zijn ook andere oplossingen om dit te doen maar deze is zo opgezet om een ALS en een EN funktie te gebruiken.

=ALS(EN(A3> 0;A3<9);1;2)

Veranderd door Gerard, 13 oktober 2009 - 19:09


#3

KoenM

    KoenM


  • 0 - 25 berichten
  • 3 berichten
  • Ervaren gebruiker

Geplaatst op 13 oktober 2009 - 19:29

Het is lastig uit te leggen wat er in B moet komen staan.
Maar ik wil dat er de volgende waarden verschijnen:

Voor 1 tot en met 9: 1
Voor 10 tot en met 189: 2
Voor 190 tot en met 2889: 3
Voor 2890 tot en met 11889: 4

Maar als ik het invul zoals het mij lijkt dat ik het in moet vullen staat er:
#WAARDE# (Er moet dus een fout zitten ergens)

#4

MarinaV

    MarinaV


  • >100 berichten
  • 129 berichten
  • Ervaren gebruiker

Geplaatst op 13 oktober 2009 - 22:49

Ik werk in zo gevallen liefst met geneste als-functies
ik heb je grenzen (10, 190, ...) in kolom F gezet, de waarden die moeten ingevuld in kolom G, en de kolom die je checkt is A.
Volgende formule doet dan het gevraagde
=ALS(A1<$F$1;$G$1;ALS(A1<$F$2;$G$2;ALS(A1<$F$3;$G$3;$G$4)))

#5

KoenM

    KoenM


  • 0 - 25 berichten
  • 3 berichten
  • Ervaren gebruiker

Geplaatst op 14 oktober 2009 - 11:04

Het is gelukt!
Bedankt allebei!





0 gebruiker(s) lezen dit onderwerp

0 leden, 0 bezoekers, 0 anonieme gebruikers

Ook adverteren op onze website? Lees hier meer!

Gesponsorde vacatures

Vacatures