Springen naar inhoud

Editor VS IE10


  • Log in om te kunnen reageren

#1

Benm

    Benm


  • >5k berichten
  • 8801 berichten
  • VIP

Geplaatst op 22 maart 2013 - 02:05

Opvallend probleempje bij het plaatsen van berichten in IE10:

In WYSIWIG mode geeft drukken op enter geen witregel of paragraaf, er gebeurd gewoon helemaal niets. Als je middels het meest linkse knopje overgaat op source weergave werkt het wel (zo krijg ik de witregels in deze post), maar dan ben je de andere functies als quoten, plaatjes etc kwijt.

Wellicht iets om even naar te kijken nu IE10 vrij rap wordt uitgerold naar bestaande windows 7 / IE9 installaties?
Victory through technology

Dit forum kan gratis blijven vanwege banners als deze. Door te registeren zal de onderstaande banner overigens verdwijnen.

#2

Ger

    Ger


  • >5k berichten
  • 16444 berichten
  • Technicus

Geplaatst op 22 maart 2013 - 08:25

Lijkt erop dat het een bug is die inmiddels door CKEditor gefixt is en dus in de nieuwste versie van Invision ook gefixt zou moeten zijn: http://community.inv...#comment_106013

Zo rondbladerend in hun bugtracker kom ik nogal wat IE10 bugs tegen in de editor, dus het kan geen kwaad om binnenkort te updaten.
"Knowledge speaks, but wisdom listens."
- Jimi Hendrix -

#3

jkien

    jkien


  • >1k berichten
  • 3053 berichten
  • Moderator

Geplaatst op 22 maart 2013 - 19:01

Het probleem dat de WSF-editor de enter-toets negeert heb ik eergisteren spontaan gekregen in IE. Ik moet mijn bijdragen nu schrijven zonder enter-toets; of anders in notepad schrijven, met een dubbele enter waar ik normaal een enkele enter zou invoeren, en dan de tekst copy-pasten naar de WSF-editor. Het probleem doet zich op mijn computer alleen voor in WSF (en alleen in IE, niet in Chrome). Vreemd.


Hee, ik zie nu dat mijn IE-browser eergisteren automagisch is geupdate van IE9 naar IE10. Dus toch een IE10-probleem.

#4

Benm

    Benm


  • >5k berichten
  • 8801 berichten
  • VIP

Geplaatst op 24 maart 2013 - 15:56

Yeah, het is een IE10 ding.

Je kunt wel enters plaatsen als je met het knopje linksboven naar code omschakelt. Niet onoverkomelijk, maar wel lastig.

IE10 wordt inmiddels naar iedereen gepushed als automatisch update, en het heeft problemen met wysiwyg editors... niet alleen die van dit forum, maar allerlei. Heeft iets te maken met veranderingen aan het document object model. Overigens kun je het wel omzeilen door de pagina in compatibility mode te bekijken.
Victory through technology

#5

In physics I trust

    In physics I trust


  • >5k berichten
  • 7384 berichten
  • Moderator

Geplaatst op 24 maart 2013 - 16:16

Overigens kun je het wel omzeilen door de pagina in compatibility mode te bekijken.

dat overigens andere lay-outs ruïneert.
"C++ : Where friends have access to your private members." — Gavin Russell Baker.

#6

Benm

    Benm


  • >5k berichten
  • 8801 berichten
  • VIP

Geplaatst op 25 maart 2013 - 02:35

Nouja, je kunt het per website instellen natuurlijk, het is geen global setting om alles wat je bezoekt meteen op die manier weer te geven.

Zo op het eerste gezicht ziet WSF er best goed uit in IE10 compatibily view, inclusief werkende editor. Het zou best kunnen dat er ergens een marge oid niet helemaal is wat het moet zijn, maar storend is het in ieder geval niet.
Victory through technology

#7

In physics I trust

    In physics I trust


  • >5k berichten
  • 7384 berichten
  • Moderator

Geplaatst op 25 maart 2013 - 07:33

Nee, je hebt gelijk: voor WSF is het een prima oplossing. Mijn frustratie kwam van het feit dat ik een nette site had ontworpen in Chrome/FF/Safari maar dat IE er weer een rommeltje van maakt ;)
"C++ : Where friends have access to your private members." — Gavin Russell Baker.

#8

Benm

    Benm


  • >5k berichten
  • 8801 berichten
  • VIP

Geplaatst op 25 maart 2013 - 13:00

Bekend fenomeen :D

Victory through technology

#9

Miels

    Miels


  • >5k berichten
  • 14506 berichten
  • Beheer

Geplaatst op 10 april 2013 - 13:55

Zou gefixed moeten zijn

Verborgen inhoud
doordat we de regel
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE9" />
hebben toegevoegd wordt de site nu standaard in IE9 modus getoond. Dus meer een work around dan een fix, maar het werkt!

Never be afraid to try something new. Remember, amateurs built the ark. Professionals built the Titanic






0 gebruiker(s) lezen dit onderwerp

0 leden, 0 bezoekers, 0 anonieme gebruikers

Ook adverteren op onze website? Lees hier meer!

Gesponsorde vacatures

Vacatures