Springen naar inhoud

maple oplossing sin(x)=0


  • Log in om te kunnen reageren

#1

jppilot

    jppilot


  • >25 berichten
  • 46 berichten
  • Gebruiker

Geplaatst op 02 november 2013 - 13:56

goedemiddag,

Met maple wil ik de vergelijking sin(x)=0 uitrekenen in de range van -1<=x<=7.
Hier moet uitkomen 0, pi en 2pi.

Echter komt er met fsolve(sin(x)=0,x=-1..7)
alleen het antwoord 3.14.... in beeld.

Hoe kan ik ervoor zorgen dat alle 3 de antwoorden afgedrukt worden?

Danku!

Dit forum kan gratis blijven vanwege banners als deze. Door te registeren zal de onderstaande banner overigens verdwijnen.

#2

Typhoner

    Typhoner


  • >1k berichten
  • 2446 berichten
  • VIP

Geplaatst op 02 november 2013 - 15:20

Ik heb geen Maple meer (dus kan niet controleren), maar ik dacht dat het zetten van
_EnvAllSolutions := true;
voorafgaand aan het solve() helpt.
This is weird as hell. I approve.

#3

jppilot

    jppilot


  • >25 berichten
  • 46 berichten
  • Gebruiker

Geplaatst op 02 november 2013 - 15:42

geprobeerd, maar lijkt niet te werken. Heel raar.

#4

tempelier

    tempelier


  • >1k berichten
  • 1765 berichten
  • Ervaren gebruiker

Geplaatst op 03 november 2013 - 22:26

Ik weet dat er een speciaal commando voor is.
Maar ik heb er naar gezocht maar kan het niet vinden.
In de wiskunde zijn er geen Koninklijke wegen Majesteit.

#5

Drieske

    Drieske


  • >5k berichten
  • 10217 berichten
  • Moderator

Geplaatst op 04 november 2013 - 09:08

Probeer eens
solve(sin(x)=0, x, AllSolutions);
Zoek je graag naar het meest interessante wetenschapsnieuws? Wij zoeken nog een vrijwilliger voor ons nieuwspostteam.

#6

tempelier

    tempelier


  • >1k berichten
  • 1765 berichten
  • Ervaren gebruiker

Geplaatst op 04 november 2013 - 18:27

Werkte niet bij mij. :cry:
In de wiskunde zijn er geen Koninklijke wegen Majesteit.

#7

Drieske

    Drieske


  • >5k berichten
  • 10217 berichten
  • Moderator

Geplaatst op 05 november 2013 - 09:16

Wat geeft dat dan bij jou? Bij mij werkt dat gewoon en krijg ik LaTeX *_Z1~

Je ziet het misschien nog beter met
solve(cos(x)=0, x, AllSolutions);
Zoek je graag naar het meest interessante wetenschapsnieuws? Wij zoeken nog een vrijwilliger voor ons nieuwspostteam.

#8

tempelier

    tempelier


  • >1k berichten
  • 1765 berichten
  • Ervaren gebruiker

Geplaatst op 05 november 2013 - 16:20

Wat geeft dat dan bij jou? Bij mij werkt dat gewoon en krijg ik LaTeX

*_Z1~

Je ziet het misschien nog beter met
solve(cos(x)=0, x, AllSolutions);


Ik krijg:

Error, (in solve) invalid arguments
In de wiskunde zijn er geen Koninklijke wegen Majesteit.





0 gebruiker(s) lezen dit onderwerp

0 leden, 0 bezoekers, 0 anonieme gebruikers

Ook adverteren op onze website? Lees hier meer!

Gesponsorde vacatures

Vacatures