Springen naar inhoud

Data verwerken


  • Log in om te kunnen reageren

#1

quizmaster

    quizmaster


  • 0 - 25 berichten
  • 2 berichten
  • Ervaren gebruiker

Geplaatst op 14 januari 2010 - 17:05

Beste allen,

Ik wil data verwerken in Excel. Even snel uitleggen waar het om gaat:

Ik heb meerdere testers, genaamd "A", "B", "C", etc. Deze staan in kolom A
In kolom B staat het aantal keer dat het voor komt, dus bijv. "100", "33" etc.

Nu is het zo, dat "A", "B" etc vele malen meer voorkomen dan één keer.

Nu wil ik graag alle "A's " en "B's "etc. bij elkaar optellen, als in "=ALS A1=A;DAN B1 WAAR) oid.

Het probleem zit het in "DAN" en het optellen.

Ik kan wel alle "A's" op alfabetische volgorde zetten en dan de som van kolom B nemen, maar dat is niet de bedoeling... :oops:

Wie heeft voor mij de tijdbesparende oplossing?

mvg

Quiz

Dit forum kan gratis blijven vanwege banners als deze. Door te registeren zal de onderstaande banner overigens verdwijnen.

#2

Fuzzwood

    Fuzzwood


  • >5k berichten
  • 11160 berichten
  • Moderator

Geplaatst op 14 januari 2010 - 17:37

Daar kun je dus som.als voor gebruiken.

In jouw voorbeeld:

A  100
B  35
A  50
A  70
B  20
B  100
B  35
A  50
A  70
A  20
B  100
B  35

Als ik dan de formule =SOM.ALS(A1:A12;"A";B1:B12) toepas in de cel waar ik het resultaat wil, dan rolt daaruit dat elk getal achter A opgeteld 360 is. Verander ik "A" in "B", dan rolt daar 325 uit, wat de som is van elk getal achter B.

Uitleg: "A" is de conditie, A1:A12 is het bereik waarop de conditie wordt vergeleken, B1:B12 bevatten de waarden gekoppeld aan A1:A12 en worden gebruikt in de optelling wanneer een cel in bereik A1:A12 aan de gestelde conditie voldoet.

Veranderd door Fuzzwood, 14 januari 2010 - 17:40


#3

quizmaster

    quizmaster


  • 0 - 25 berichten
  • 2 berichten
  • Ervaren gebruiker

Geplaatst op 18 januari 2010 - 13:40

Aah, mijn dank is groot! Ik vond van het weekend ook de presentatie van een draaitafel, dat lukt ook, maar dit is makkelijker!

grtz





0 gebruiker(s) lezen dit onderwerp

0 leden, 0 bezoekers, 0 anonieme gebruikers

Ook adverteren op onze website? Lees hier meer!

Gesponsorde vacatures

Vacatures